Posted on

Installare Rawstudio e Qtpfsgui su GNU/Linux

INFO Esperienza svolta su un sistema Ubuntu 8.10 Hardy Heron 32bit.

Oggi vediamo come installare Rawstudio e Qtpfsgui, due importanti applicazioni opensource per gestire, rispettivamente, le immagini in formato RAW e i lavori in HDR.

Ecco le dipendenze che ho dovuto soddisfare nel mio sistema, per preparare la corretta compilazione di rawstudio.

sudo apt-get install libdbus-1-dev libdbus-glib-1-dev libgconf2-dev libgtk2.0-dev

wget http://rawstudio.org/files/release/rawstudio-1.2.tar.gz
tar zxvf rawstudio-1.2.tar.gz
cd rawstudio-1.2/
./configure && make && sudo make install

Per quanto riguarda le dipendenze di Qtpfsgui invece riguardavano soprattutto le libqt4, dal momento che questo programma è scritto in Qt4:

sudo apt-get install libqt4-dev libexiv2-dev fftw3-dev openexr libopenexr-dev libtiff-dev

poi scaricare il pacchetto:

wget http://garr.dl.sourceforge.net/sourceforge/qtpfsgui/qtpfsgui-1.9.3.tar.gz
tar zxvf qtpfsgui-1.9.3.tar.gz
cd qtpfsgui-1.9.3/
qmake-qt4 && make && sudo make install

INFO Esperienza svolta su un sistema Ubuntu 9.04 Jaunty Jackalope 64bit.

L’esperienza dell’installazione di rawstudio è stata ripetuta anche su un sistema 64bit e le dipendenze richieste sono state le seguenti:

sudo apt-get install libdbus-1-dev libdbus-glib-1-dev libgconf2-dev libgtk2.0-dev libxml2-dev libxml2

Mentre le dipendenze per Qtpfsgui sonostate:

sudo apt-get install libqt4-dev libexiv2-dev fftw3-dev openexr libopenexr-dev libtiff4-dev