Pubblicato il

Problemi con Stellarium su Linux Debian Squeeze

StellariumScorsa settimana ho installato il nuovo sistema operativo Debian Squeeze sul mio solito pc portatile, ed ho subito installato, da repository, Stellarium, versione 0.10.4, il noto planetario open source.

Mi sono trovato di fronte a due problemi abbastanza inaspettati, o forse no. Il primo riguarda un’eccessiva lentezza nella risposta ai comandi o nella navigazione tra i vari menù. A tal proposito, a coloro che hanno maggiore dimestichezza mi sento di consigliare la modifica manuale tramite un editor del file /home/user/.stellarium/config.ini.

Il secondo problema invece riguarda la linea dell’orizzonte e del panorama (di default è selezionato guereins). Di fatto quello che appare è una specie di muraglia verde, abbastanza alta, senza punti cardinali.

Ho solo parzialmente risolto installando la versione SVN (istruzioni qui) che non è altro che la pre-release della versione 0.10.5.
Ora la lentezza è sempre presente, immagino a causa delle librerie Qt oppure dei driver open della mia scheda grafica, una ATI Mobility Radeon X1300. Il problema del paesaggio invece è stato risolto, ora appare correttamente. Tuttavia ho riscontrato altri problemi, evidenti nello screenshot che allego. Le scritte e le didascalie nei menù sono illeggibili, mentre non tutte le funzioni selezionate sono visibili. Infatti mentre le linee delle costellazioni e le figure artistiche non presentano problemi, lo stesso non si può dire per i confini delle costellazioni. I punti cardinali continuano ad essere invisibili.

Cosa aggiungere? Sarebbe bello se a Stellarium su Linux fosse dedicata maggiore attenzione alla risoluzione dei (soliti) problemi. Da parte mia prossimamente cercherò si segnalare tali problemi agli sviluppatori.

Continuate a leggere le pagine di questo blog, abbonatevi ai Feed RSS o seguitemi su Twitter.

5 pensieri su “Problemi con Stellarium su Linux Debian Squeeze

  1. Premetto che parlo da inesperta ma per il fattore lentezza ti seguo a ruota. Ho installato la nuova versione da un pò di tempo ed è praticamente inutilizzabile.Vabè che la mia scheda grafica è preistorica però chiedendo in giro ho riscontrato lo stesso problema anche in casi in cui la scheda grafica non era proprio da buttare, anzi…:/

  2. Ho ubuntu e anche a me stellarium pone gli stessi problemi, il panorama default sembra un muroi verde, non ho i punti cardinali però le scritte si vedono bene… ha dimenticavo anche a me è lento da morire :-!

  3. Non so a cosa sia dovuta la lentezza di Stellarium, certo è che se pure su Windows quelli di Stellarium non rilasciano una versione -meno pesante- allora sì che è un problema. In verità, come ho già detto nell'articolo, credo dipenda tutto dalla versione dei driver installati sul sistema operativo; nel mio caso purtroppo ho una VGA abbastanza vecchia… :-/

  4. Sì, M0rF3uS hai ragione! Posso molto probabilmente con l'ultimo trunk svn dovresti risolvere. anche tu 🙂

  5. La lentezza è dovuto all'enorme potere di calcolo richiesto alla gpu, se i driver non son ben fatti scatta un pò. Su ubuntu+nvidia a me scatta a volte, mentre su ubuntu+intel non scatta perchè evidentemente i driver sono meglio scritti, però ho la fastidiosa scia verde a metà schermo, devo seleizonare come paesaggio marte o luna per eliminarla :/ proverò ad installare l'ultimo trunk svn

I commenti sono chiusi.