Pubblicato il

Installare gPhoto2 per gestire dal pc la CANON EOS-450D

INFOEsperienza svolta su un sistema Ubuntu Hardy Heron 8.10 32bit.

GPhoto2 è un ottima applicazione in grado di gestire le moderne fotocamere digitali, reflex comprese, in ambiente linux.
Lungo il tragitto della compilazione di GPhoto2 sul mio pc mi sono imbattuto nella mancanza dei seguenti pacchetti, che pertanto consiglio di far trovare già sul sistema, prima dell’installazione che andremo ad effettuare tra poco.

sudo aptitude install libgtk2.0-dev libexif-dev libexif-gtk pptpd-dev libpopt-dev libusb-dev libltdl7-dev libfuse-dev

Poi scarichiamo le ultime versioni di libgphoto2 e gphoto2 e, solo se vogliamo un comodo front-end, anche gtkam
http://sourceforge.net/project/showfiles.php?group_id=8874

oppure da terminale partendo dalla Home:

cd ~

wget http://puzzle.dl.sourceforge.net/sourceforge/gphoto/gphotofs-0.4.0.tar.gz
&& wget http://puzzle.dl.sourceforge.net/sourceforge/gphoto/libgphoto2-2.4.6.tar.gz && wget http://puzzle.dl.sourceforge.net/sourceforge/gphoto/gphoto2-2.4.5.tar.gz && wget http://puzzle.dl.sourceforge.net/sourceforge/gphoto/gtkam-0.1.16.1.tar.gz

poi scompattiamo l’archivio:

tar zxvf libgphoto2-2.4.6.tar.gz
cd libgphoto2-2.4.6/
./configure
make
make install
cd ..
tar zxvf gphoto2-2.4.5.tar.gz
cd gphoto2-2.4.5/
./configure
make
make install
cd ..
tar zxvf gphotofs-0.4.0.tar.gz
cd gphotofs-0.4.0
./configure
make
make install
cd ..
tar zxvf gtkam-0.1.16.1.tar.gz
cd gtkam-0.1.16.1/
./configure
make
make install

Dopo l’installazione, non ho trovato Gtkam nel menù di sistema, è possibile però lanciarlo semplicemente da terminale, tramite il comando:

gtkam

Chiaramente è possibile creare l’icona nel menù, recandosi su: Sistema -> Preferenze -> Menù principale

4 pensieri su “Installare gPhoto2 per gestire dal pc la CANON EOS-450D

  1. Ciao,

    ho seguito la procedura ma ho un problema con l'installazione di libgphoto2
    appending configuration tag “F77” to libtool
    checking ltdl.h usability… no
    checking ltdl.h presence… no
    checking for ltdl.h… no
    checking that we can compile and link with libltdl… no
    configure: error: cannot compile and link against libltdl
    libgphoto2 requires libltdl (the libtool dl* library),
    but cannot compile and link against it.
    Aborting.

    Ti dice qualcosa??
    Grazie in anticipo,
    Michele

  2. Ciao Michele, innanzitutto dovresti dirmi quale distro usi, che versione e poi anche quale versione di libgphoto2 stai tentando di installare, ora è uscita la 2.4.8 -> http://sourceforge.net/projects/gphoto/files/

    In ogni caso il messaggio di errore è “chiaro”, ti manca il pacchetto libltdl-devel che devi installare a parte. Fammi sapere se risolvi.

  3. ciao, sto seguendo la tua guuida, complimenti per il lavoro.
    Sto installando le ultime versioni di lib 2.5.1.1 e photo 2.5 ma durante il config di gphoto si ferma l’installazione con questo messaggio

    configure: error:
    PKG_CONFIG_PATH=
    LIBGPHOTO2_LIBS=
    LIBGPHOTO2_CFLAGS=

    * Fatal: gphoto2 command line interface requires libgphoto2 >= 2.4.10 to build.
    *
    * Possible solutions:
    * – set PKG_CONFIG_PATH to adequate value
    * – call configure with LIBGPHOTO2_LIBS=.. and LIBGPHOTO2_CFLAGS=..
    * – call configure with one of the –with-libgphoto2 parameters
    * – get libgphoto2 and install it:

    Puoi darmi un consiglio per superare il problema? Grazie

I commenti sono chiusi.